Gmail Will No Longer Support Chrome Version 53 And Below

posted Feb 22, 2017, 10:28 AM by Amanda Hudeck

Starting February 8, 2017, Google began showing a banner at the top of the Gmail interface for those who are still on Google Chrome Browser v53 and below encouraging them to upgrade to the latest version of Chrome (at least version 55). The reason for this is that Chrome Browser v55 contains several important security updates. MiWorkspace computers will auto-update and are running version 56.


What happens if you continue to use Chrome Browser v53 and below?

  • Gmail will continue to function on Chrome Browser v53 and below through the end of the 2017.

  • Gmail will be more vulnerable to security risks and users will not have access to new features and bugfixes.

  • You could be redirected to the basic HTML version of Gmail as early as Dec 2017.

The Collaboration Services Team


Tip: Did you know? You can show more or show less from a community in Google+

Learn more about Google at the G Suite Learning Center


Comments